VarSeq 1.3.2 Release Notes

New Features

  • Added Annotate Transcripts algorithm to the Add > Computed Data menu. Running the Annotate Transcripts through the Computed Data dialog includes the option to modify parameters which includes specifying the splice site boundaries. See Annotate Transcript for more information.
  • Added Match Sample Gene List algorithm to the Add > Computed Data menu. This new algorithm determines gene matches based on sample specific gene lists.
  • Added VSPipeline command to import new samples plus the existing samples into a new project.
    project_open path="D:/ExistingProject"
    import project_path="D:/NewProjectPath" file="D:/NewFileToImport.vcf"

Bugs Fixed

  • Allow for import from and export to paths containing extended unicode characters. This includes support for Japanese and Arabic languages among others.
  • Fixed reported time to import data in the detailed information of the Log.
  • Prevent creating a variant database without a path specified.
  • VSPipeline bugs fixed:
    • Batch files containing the exit command no longer crashes.
    • Exporting all samples (affected_only = False in the foreach_sample command) no longer crashes.
  • Fixed the issue with renaming samples in the Import Wizard.
  • Removed empty dialog when canceling out of the “Project Newer Than Software” warning.
  • Update table when using table expressions and switching between samples.
  • Prevent crash when trying to change a Container to a Local folder in the Data Source Library.
  • Prevent crash when opening the Data Source Library if the source tree contains a local source that was watching a folder that was deleted while the program was closed.
  • Ensure that the Data Source Library downloads to the annotation folder set in Tools > Options … unless a different path is set through GenomeBrowse options.
  • Updated shipped VSReports templates to fix error when selecting variants that are missing optional OMIM annotations that are used to auto-fill report fields.
  • Fixed issue with Convert Wizard that caused the data preview to be missing for all supported file types.
  • Guard Variant Assessment database schema removal crash (clicking on the “-” button) when a row/field has not been selected.
  • In GenomeBrowse for BAM alignment plots, remember the edited value for Filter Multi-Mapped Alignments when the option is checked and unchecked.
  • Fixed issue with loading feature information into the Details view when clicking on Interval sources in GenomeBrowse.
  • Better error handling for coverage statistics and mapping of regions back to variants.
  • Make sure that all executables have the correct permissions for Linux x64, RHEL and Mac OSX builds (aria2c, assistant, etc.).
  • After updating, relaunch VarSeq instead of trying to launch Golden Helix SVS.

Polishes

  • Allow Import to use multiple threads for faster import of data in multiple files.
  • Import no longer creates a sample table when importing sites only variant files.
  • Allow for coverage computation for VCF files in GenomeBrowse that do not contain a Genotype (GT) field but does have other sample level FORMAT files.
  • Renamed Annotation Download Window buttons to make it clear that downloaded tracks will not be deleted through this dialog.
  • Created more informative error message when the Database Folder path is is not valid.
  • Update Alternate Allele Frequency calculation to pull data from the sample level FORMAT fields when available.
  • Make error message more informative when downloading annotation sources to a location that is out of space.


Feedburner  Subscribe in a reader or via email

« Back to Support Bulletin List