VarSeq 1.2.2 Release Notes

New Features

  • VarSeq Reports are now available! Golden Helix has added the ability to generate clinical reports for a select set of variants using custom templates to meet individual specifications. For more information see Clinical Reporting and contact your account manager to get access to VarSeq Reports.
  • Added the ability to create record sets or flags to select variants, samples, or coverage regions either by hand or by selecting/adding all variants in the current table view. See Record Sets for more information.
  • Added a software updater which starting with the upgrade from 1.2.2 to later versions will now download only modified files making the upgrade faster and allow for installation of the update at the same time or at a later time.
  • A new mini demo project Example YRI Exome Trio Analysis is available by going to File > Open Example Project.
  • Support plotting numeric array fields in GenomeBrowse.
  • Created menu item Tools > Options that allows the user to change the location of the Common Data and User Data folders in VarSeq.

Bugs Fixed

  • Prevent crash when exporting to VCF files with Genotype G_T or Zygosity fields were moved to be above the numeric GT field and other sample FORMAT fields.
  • Fixed searching indexed fields in GenomeBrowse when annotation sources are loaded from Public Repository.
  • Fixed coverage regions being listed out of order and not in natural chromosome order.
  • Computation on computed fields now working correctly. For example after running the Allele Counts algorithm, creating a computed field of Allele Counts / Alleles now returns the correct allele frequency value instead of all missing values.
  • Added the functionality to the table_export_xlsx and table_export_multiple_xlsx commands for VSPipeline to ignore the saved export path and instead use the current working directory.
  • Correctly collapse intergenic sequence ontology and effect fields for Annotate by Transcript algorithm (intergenic_variant sequence ontology should be collapsed into the “Other” Effect category for Clinically Relevant transcripts.
  • On MacOS X, when importing data through the Import Wizard and linking BAM files, after selecting the last BAM file, link the last BAM file even if the cursor is still in the file selection box when clicking “OK”.
  • Fixed issue with hyperlinks in internal Web Browser when links are set to open new views.
  • Fixed error caused by multiple algorithms writing to the same file which caused the database schema to become locked and not finish.

Polishes

  • Allow offline activation of VarSeq license when server connection is refused by local network.
  • Excel XLSX Export:
    • Changed default file name for multiple table Excel export to be the sample name as it is for single table Excel export.
    • Changed the tab names for Excel export to be more informative with the limited characters allowed for tab names.
  • Fixed display of the “Merge Behavior” column in the advanced option dialog for Variant Import on MacOS X for those options that cannot be changed. The behavior was blurred so that it was unreadable.
  • Fixed display of the Coverage Stats options dialog on MacOS X.
  • Created the menu item File > Open Example Project to open menu containing a list of complete example projects shipped with VarSeq.
  • The visible column groups and columns for each table type are now stored such that:
    • When changing the table type in the table selection box, if the table has been previously viewed the visibility preferences are restored.
    • The visibility preferences for that particular table type are lost when the Table View tab is closed.
    • When a table type has not previously been viewed, the preferences are copied from an existing view of that table type if it exists.
    • The preferences for each table tab and its type are preserved when the VarSeq project is saved, closed and reopened.
  • When visualizing annotation sources in GenomeBrowse set labels in the following preferred order: “Identifier” > “Ref/Alt” > “Gene Name” > “Name”
  • Changed the controls for opening a existing note, creating a new note and deleting an existing note to match the new style of table selection.
  • Polished the default names for the Note View initial view and for an untitled note.
  • Added the gvcf extension to the recognized import file selection list.
  • Allow selection of a remote source for specifying regions when computing coverage statistics and download the source before running the algorithm.
  • Allow indexing of string array fields for annotation sources. This supports querying against these fields in GenomeBrowse.


Feedburner  Subscribe in a reader or via email

« Back to Support Bulletin List